Order Status Update Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted May 12, 2020 - 09:01 PDT
Investigating
Some users are experiencing issues with order status updates. We are working to resolve this issue as soon as possible.

20190615-875357-2636238
Posted May 12, 2020 - 07:55 PDT
This incident affected: Order Status Updates.