Delayed Dividend Payments (11/12 - 11/21 Pay Dates)
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted 6 months ago. Nov 23, 2018 - 06:53 PST
Update
We have resolved an issue which caused dividends with a Record Date of 11/9 or earlier and a Payment Date of 11/21 or earlier to be delayed. These dividends have now been paid and should be reflected in your account.
Posted 6 months ago. Nov 21, 2018 - 16:36 PST
Monitoring
We are aware that some recent dividends may be delayed or appear as "pending" in the app, and are on track to pay you your dividends shortly. You should see those entries and the associated value restored in your app soon.
Posted 6 months ago. Nov 21, 2018 - 10:10 PST
This incident affected: Corporate Actions (Dividends).