July 2, 2021
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Jul 02, 2021 - 17:58 PDT
Update
We are continuing to investigate this issue.
Posted Jul 02, 2021 - 17:57 PDT
Update
We are continuing to investigate this issue.
Posted Jul 02, 2021 - 17:51 PDT
Investigating
We’re currently experiencing crypto trading and display issues on Robinhood. We’re working to resolve them as soon as possible.
Posted Jul 02, 2021 - 17:23 PDT
This incident affected: Trading (Crypto Trading).