Issues with margin call restrictions for some users.
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted about 1 month ago. Apr 24, 2019 - 11:38 PDT
Investigating
Investigating
Posted about 1 month ago. Apr 24, 2019 - 08:11 PDT
This incident affected: Trading (Equities Trading).