Phone Support Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Mar 17, 2022 - 08:46 PDT
Investigating
We’re investigating reports that some customers are unable to request phone support. We’re working to resolve the issue as soon as possible. Please be aware that the option to email customer support is still available from the app.
Posted Mar 17, 2022 - 07:37 PDT
This incident affected: Customer Support (Phone Support).