Crypto Trading Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Apr 27, 2021 - 21:43 PDT
Update
Customers may be seeing crypto orders display as "pending" for an extended period of time. We were experiencing a delay in order status updates and will provide an update here when the issue is resolved.
Posted Apr 27, 2021 - 19:35 PDT
Investigating
We are experiencing issues with crypto trading. We are working to resolve this as soon as possible.
Posted Apr 27, 2021 - 19:27 PDT
This incident affected: Trading (Crypto Trading).