Web Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Jan 27, 2021 - 07:25 PST
Investigating
We are experiencing a service disruption with our Web app. Our iOS and Android apps are still operational. We are working to resolve this issue as soon as possible.
Posted Jan 27, 2021 - 07:03 PST
This incident affected: Apps (Web App).