Crypto Degraded Service
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Nov 14, 2019 - 01:10 PST
Update
We are continuing to investigate this issue.
Posted Nov 14, 2019 - 01:06 PST
Update
We are continuing to investigate this issue.
Posted Nov 14, 2019 - 01:01 PST
Investigating
We are currently investigating this issue.
Posted Nov 14, 2019 - 00:41 PST
This incident affected: Trading (Crypto Trading).