Password Reset Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 24, 2019 - 14:32 PDT
Investigating
Some users are experiencing issues resetting their passwords and logging in with 2-factor authentication.
Posted 3 months ago. Jul 24, 2019 - 14:06 PDT