Bank Transfer Issues
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Sep 17, 2019 - 10:35 PDT
Identified
Some users are experiencing delays with bank transfers. We are working to resolve this issue as soon as possible.

20190615-875357-2636238
Posted Sep 17, 2019 - 08:47 PDT
Investigating
Some users are experiencing delays with bank transfers. We are working to resolve this issue as soon as possible.

20190615-875357-2636238
Posted Sep 17, 2019 - 06:44 PDT
This incident affected: Bank Transfers.