Duplicate ACH Cash Transfers
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted 2 months ago. May 15, 2019 - 10:30 PDT
Investigating
If you experienced an issue with failed ACH cash transfers and have duplicate transfers pending, you should now be able to cancel those duplicate transfers.
Posted 2 months ago. May 15, 2019 - 07:23 PDT
This incident affected: Bank Transfers.