Bank Transfer Issues
Incident Report for
Robinhood
Resolved
This incident has been resolved.
Posted
Nov
04
,
2019
-
12:42
PST
Update
We are continuing to investigate this issue.
Posted
Nov
04
,
2019
-
12:26
PST
Investigating
Some users are experiencing issues with bank transfers. We are working to resolve this issue as soon as possible.
20190615-875357-2636238
Posted
Nov
04
,
2019
-
12:24
PST
This incident affected: Bank Transfers.
×
Subscribe to Incident
Subscribe to updates for
Bank Transfer Issues
via . You'll receive .