Crypto Trading Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Nov 19, 2020 - 19:31 PST
Update
We are continuing to monitor for any further issues.
Posted Nov 19, 2020 - 19:16 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 19, 2020 - 19:00 PST
Investigating
We are experiencing issues with crypto trading. We are working to resolve this as soon as possible.
Posted Nov 19, 2020 - 18:49 PST
This incident affected: Trading (Crypto Trading).