Outage
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Oct 07, 2019 - 23:08 PDT
Update
We are continuing to investigate this issue.
Posted Oct 07, 2019 - 21:18 PDT
Investigating
We are currently investigating this issue.
Posted Oct 07, 2019 - 21:17 PDT
This incident affected: Overall System (Overall System).