Equities, Options, and Crypto Trading Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Nov 06, 2019 - 09:54 PST
Investigating
We are experiencing issues with equities, options, and crypto trading. We are working to resolve this issue as soon as possible.

20190615-875357-2636238
Posted Nov 06, 2019 - 06:43 PST
This incident affected: Trading (Equities Trading, Crypto Trading, Options Trading).