System-Wide Outage
Incident Report for Robinhood
Resolved
Robinhood is now fully restored. We know this has been frustrating and we will work diligently to provide the level of service you deserve.
Posted Mar 03, 2020 - 08:55 PST
Update
Service has been partially restored on Robinhood and we’re working toward restoring and maintaining full functionality.
Posted Mar 03, 2020 - 08:35 PST
Investigating
We are experiencing a system-wide outage. We are working to resolve this issue as soon as possible.
Posted Mar 03, 2020 - 07:04 PST
This incident affected: Overall System (Overall System), Trading (Equities Trading, Crypto Trading, Options Trading), Apps (iOS App, Web App, Android App), and Order Status Updates, Bank Linking, Bank Transfers, Email Support.