Bank Linking and Transfer Issues
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Mar 22, 2021 - 18:40 PDT
Identified
We’re working to resolve the issue that’s currently impacting bank linking and transfers. We’re sorry to anyone impacted for any disruption. Please note, trading is functional and not affected.
Posted Mar 22, 2021 - 16:17 PDT
Investigating
Some customers are reporting issues with bank transfers. We are working to resolve this as soon as possible.
Posted Mar 22, 2021 - 15:04 PDT
This incident affected: Bank Transfers.