Erroneous ACH Transfer Failure Messages
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted 2 months ago. May 15, 2019 - 07:19 PDT
Investigating
Some users are seeing messages that their ACH cash transfers have failed when in fact they have not. We are working to resolve this issue as soon as possible.
Posted 2 months ago. May 15, 2019 - 06:28 PDT
This incident affected: Bank Transfers.