Crypto Trading Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Apr 13, 2021 - 00:07 PDT
Investigating
We are experiencing issues with crypto trading. We are working to resolve this as soon as possible.
Posted Apr 12, 2021 - 23:03 PDT
This incident affected: Trading (Crypto Trading).