Equities, Options & Crypto Trading Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Mar 09, 2020 - 12:31 PDT
Update
Trading on Robinhood has been functional for new orders with the exception of fractional equities since at least 10:25 AM ET.
Posted Mar 09, 2020 - 10:20 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 09, 2020 - 07:30 PDT
Investigating
We are experiencing issues with equities, options and crypto trading. We are working to resolve this issue as soon as possible.

20190615-875357-2636238
Posted Mar 09, 2020 - 06:51 PDT
This incident affected: Trading (Equities Trading, Crypto Trading, Options Trading).