Debit Card Issues
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Jul 22, 2020 - 09:06 PDT
Investigating
Debit card functionality is currently down, due to an issue with a third party vendor. We are monitoring this issue closely and working with the vendor to resolve this as quickly as possible.
Posted Jul 22, 2020 - 09:04 PDT
This incident affected: Apps (iOS App, Web App, Android App) and Debit Card.