Market Data Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Nov 14, 2019 - 06:39 PST
Update
Our Level 2 market data is currently unavailable. We are working to resolve this issue as soon as possible.
Posted Nov 14, 2019 - 06:34 PST
Investigating
Some users are experiencing issues with incorrect market data. We are working to resolve this issue as soon as possible.

20190702-889849-2676679
Posted Nov 14, 2019 - 06:14 PST
This incident affected: Market Data.