Web and Crypto Trading Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Sep 14, 2021 - 16:21 PDT
Investigating
We’re experiencing issues affecting some crypto orders and some customers’ ability to use our web app. We’re working to resolve these issues as soon as possible.
Posted Sep 14, 2021 - 16:13 PDT
This incident affected: Apps (Web App) and Trading (Crypto Trading).