Robinhood Crypto Unavailable on Desktop
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted 25 days ago. Jun 28, 2019 - 13:22 PDT
Investigating
We’re currently unable to support Robinhood Crypto on desktop. We apologize for any
inconvenience and will restore access as soon as possible. You can still sell on Robinhood Crypto
using the Robinhood mobile app.

20190628-887494-2670932
Posted 25 days ago. Jun 28, 2019 - 12:32 PDT
This incident affected: Trading (Crypto Trading) and Apps (Web App).