Equities and Crypto Trading Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Aug 22, 2019 - 13:59 PDT
Investigating
We are experiencing issues with equities and crypto trading. We are working to resolve this issue as soon as possible.

20190615-875357-2636238
Posted Aug 22, 2019 - 13:30 PDT
This incident affected: Trading (Equities Trading, Crypto Trading).