Market Data Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Apr 20, 2020 - 12:17 PDT
Investigating
Some users are experiencing issues with delayed or incorrect market data. We are working to resolve this issue as soon as possible.

20190615-875357-2636238
Posted Apr 20, 2020 - 12:12 PDT
This incident affected: Market Data.