Market Data Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Nov 14, 2019 - 07:37 PST
Identified
Our Level 2 market data is currently unavailable. We are working to resolve this issue as soon as possible.
Posted Nov 14, 2019 - 06:40 PST
This incident affected: Market Data.