Margin Restriction Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted 3 months ago. May 24, 2019 - 10:14 PDT
Investigating
We are experiencing issues with margin call restrictions. We are working to resolve this issue as soon as possible.
Posted 3 months ago. May 24, 2019 - 06:52 PDT
This incident affected: Trading (Equities Trading).