Crypto Trading Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Jan 08, 2021 - 08:12 PST
Investigating
We are experiencing issues with crypto trading. We are working to resolve this as soon as possible.
Posted Jan 08, 2021 - 07:35 PST
This incident affected: Trading (Crypto Trading).