System-Wide Outage
Incident Report for
Robinhood
Resolved
This incident has been resolved.
Posted
Nov
14
,
2019
-
09:02
PST
Update
We are continuing to investigate this issue.
Posted
Nov
14
,
2019
-
08:53
PST
Update
We are continuing to investigate this issue.
Posted
Nov
14
,
2019
-
08:49
PST
Investigating
We are experiencing a system-wide outage. We are working to resolve this issue as soon as possible.
20190615-875357-2636238
Posted
Nov
14
,
2019
-
08:48
PST
This incident affected: Overall System (Overall System), Trading (Equities Trading, Crypto Trading, Options Trading), and Apps (Web App).
×
Subscribe to Incident
Subscribe to updates for
System-Wide Outage
via .