Crypto Trading Issue
Incident Report for Robinhood
Resolved
Buying on Robinhood Crypto is back. After reaching an unexpected volume of crypto orders, we updated our systems so that they can better scale. We know this was a big inconvenience and we appreciate your patience.

887818
Posted 3 months ago. Jun 30, 2019 - 12:55 PDT
Update
Buying crypto is paused—but you can still sell. We’re working to get fully up and running as soon as possible.

887816
Posted 3 months ago. Jun 28, 2019 - 20:45 PDT
Investigating
We’re currently unable to support buying on Robinhood Crypto. We apologize for any inconvenience and will restore access as soon as possible. You’re still able to sell crypto as usual.

887456
Posted 3 months ago. Jun 28, 2019 - 12:09 PDT
This incident affected: Trading (Crypto Trading).