Market Data Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Jun 03, 2020 - 08:28 PDT
Investigating
Some users are experiencing issues with delayed options market data. We are working to resolve this issue as soon as possible.

20190702-889849-2676679
Posted Jun 03, 2020 - 08:19 PDT
This incident affected: Market Data.