Website Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Nov 09, 2021 - 10:38 PST
Investigating
We are currently experiencing issues with our logged-out website. Logged-in customers can still use our web platform as usual. Please visit robinhood.com/login if you are attempting to sign up or log in to your account on Web.
Posted Nov 09, 2021 - 08:25 PST
This incident affected: Login.