Trading Degraded
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Dec 01, 2021 - 18:53 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 01, 2021 - 16:22 PST
Update
We are continuing to investigate this issue.
Posted Dec 01, 2021 - 15:44 PST
Investigating
We’re investigating an issue that’s affecting crypto trading and working to resolve it as soon as possible.
Posted Dec 01, 2021 - 15:04 PST
This incident affected: Trading (Crypto Trading).