Login Issues
Incident Report for Robinhood
Resolved
We fixed the issue that was affecting some customers’ ability to log in to their accounts. Customers should now be able to log in without trouble.
Posted Nov 11, 2021 - 09:47 PST
Investigating
We’re investigating reports that customers are having trouble logging in to their accounts. We’re working to resolve this issue as soon as possible.
Posted Nov 11, 2021 - 08:08 PST
This incident affected: Login.