Margin Restriction Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted 5 months ago. May 22, 2019 - 09:28 PDT
Investigating
We are experiencing issues with margin call restrictions. We are working to resolve this issue as soon as possible.
Posted 5 months ago. May 22, 2019 - 07:24 PDT
This incident affected: Trading (Equities Trading).