Crypto Maintenance
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Nov 01, 2020 - 20:30 PST
Monitoring
We're upgrading our systems to make the Crypto experience even better, so cryptocurrency trades won't execute right now.

1061471
Posted Nov 01, 2020 - 20:00 PST
This incident affected: Trading (Crypto Trading).