Equities, Options, and Crypto Trading Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Jan 28, 2021 - 08:40 PST
Update
We are continuing to investigate this issue.
Posted Jan 28, 2021 - 07:02 PST
Investigating
We are experiencing issues with crypto trading. We are working to resolve this as soon as possible.
Posted Jan 28, 2021 - 06:32 PST
This incident affected: Trading (Equities Trading, Crypto Trading, Options Trading, Fractional Equities Trading).