Order Status Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Mar 26, 2019 - 09:37 PDT
Identified
Some users are experiencing delays in order status updates. We are working to resolve this issue as soon as possible.
Posted Mar 26, 2019 - 09:26 PDT
This incident affected: Order Status Updates.