Market Data Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted 21 days ago. Jul 02, 2019 - 10:17 PDT
Investigating
Some users are experiencing issues with historical market data. We are working to resolve this issue as soon as possible.

20190702-889849-2676679
Posted 22 days ago. Jul 02, 2019 - 07:05 PDT
This incident affected: Market Data.