Trailing Stop Orders
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted 23 days ago. Sep 25, 2019 - 19:13 PDT
Investigating
We are temporarily disabling trailing stop orders on our platform. Users will not be able to place new trailing stop orders. Existing trailing stop orders should not be impacted at this time.

963876
Posted 23 days ago. Sep 25, 2019 - 12:47 PDT
This incident affected: Trading (Equities Trading).