Order Cancellation Delays
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted 24 days ago. Sep 24, 2019 - 10:29 PDT
Investigating
Some users are experiencing delays with cancelling orders. We are working to resolve this issue as soon as possible.

961619
Posted 24 days ago. Sep 24, 2019 - 07:12 PDT
This incident affected: Order Status Updates.