Crypto Trading Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Dec 21, 2020 - 02:07 PST
Update
We are continuing to investigate this issue.
Posted Dec 20, 2020 - 20:55 PST
Update
We are continuing to investigate this issue.
Posted Dec 20, 2020 - 20:09 PST
Investigating
We are experiencing issues with crypto trading. We are working to resolve this as soon as possible.
Posted Dec 20, 2020 - 17:19 PST
This incident affected: Trading (Crypto Trading) and Apps (Web App).