Equities, Options, and Crypto Trading Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Nov 10, 2020 - 08:18 PST
Investigating
We are experiencing issues with equities, options, and crypto trading. We are working to resolve this as soon as possible.
Posted Nov 10, 2020 - 07:34 PST
This incident affected: Trading (Equities Trading, Crypto Trading, Options Trading, Fractional Equities Trading) and Order Status Updates.