Crypto Trading Issue

Incident Report for Robinhood

Resolved

This incident has been resolved.
Posted Mar 29, 2022 - 16:59 PDT

Investigating

We are experiencing issues with crypto trading. We are working to resolve this as soon as possible.
Posted Mar 29, 2022 - 16:45 PDT