Crypto Trading Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted May 08, 2021 - 22:00 PDT
Investigating
We are experiencing issues with crypto trading. We are working to resolve this as soon as possible.
Posted May 08, 2021 - 21:03 PDT
This incident affected: Trading (Crypto Trading).