Order Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted 5 months ago. May 02, 2019 - 18:16 PDT
Update
The issue has been resolved.
Posted 5 months ago. May 02, 2019 - 18:15 PDT
Investigating
We are experiencing an issue that is affecting orders. New orders cannot be placed at this time. We are aware of this issue and have all hands on deck working to resolve it as soon as possible.
Posted 5 months ago. May 02, 2019 - 18:14 PDT
This incident affected: Trading (Equities Trading, Crypto Trading, Options Trading).