Bank Transfer Issues
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Nov 09, 2021 - 07:45 PST
Investigating
We’re investigating reports that some customers are experiencing issues transferring money in and out of Robinhood. We’re working to resolve this as soon as possible.
Posted Nov 09, 2021 - 07:06 PST
This incident affected: Bank Linking and Bank Transfers.