Service Interruptions
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Sep 26, 2021 - 22:51 PDT
Investigating
We’re experiencing intermittent service interruptions across our platforms and are working to resolve this issue as soon as possible.
Posted Sep 26, 2021 - 21:53 PDT
This incident affected: Apps (iOS App, Web App, Android App).