Bank Account Linking Issue
Incident Report for Robinhood
Resolved
This incident has been resolved.
Posted Jan 29, 2021 - 00:40 PST
Investigating
Some customers are reporting issues linking their bank accounts. We are working to resolve this as soon as possible.
Posted Jan 29, 2021 - 00:00 PST
This incident affected: Bank Linking.